カテゴリー別アーカイブ: html5shiv.js

HTML5は「IE8」以下(「IE9」未満)に対応していない・・・・・・じゃあ、対応させる方法と、その雛形!

Oh no.. IE8 is out!
Oh no.. IE8 is out! / cvander

 意外と知らない、というか、誰かが教えてくれないとなかなか気づかないのだが、HTML5は「IE8」以下、「IE7」、「IE6」・・・には対応していない。
  ※IE・・・Internet Explorerの略、マイクロソフトが開発するWEBブラウザのこと

 もう多くのサイトが「IE6」以下は切り捨てているのだが、まだまだ普及している「Windows XP」は「IE8」までしか使用できないので、どうしてもHTML5でサイトデザインしたい! という人は、「Windows XP」ユーザーのことも配慮して、「IE8」以下にもHTML5デザイン対策を施した方が良いと思う。

 そうしないと、「IE8」以下で閲覧した時にレイアウトが崩れてしまって、あら、こんなサイト見たくないわ、と折角のユーザーが逃げて行ってしまう。私のお母ちゃんも「Windows XP」ユーザーなので見捨てないでほしい。

 あ、巷でよく誤解されているのだが(もしかしたらこのページに来た人もそうかもしれないが)、”「IE8」以下対応”というのは、「IE8」以下で閲覧しても「HTML5的な動きが実現できる」ということではなくて、あくまでも「レイアウト崩れを起こさない防止策」に過ぎない。

  続きを読む